SHOP PRODUCTS
Houzz Logo Print
lynnalexandra

Troubleshooting My Sluggish, DisconnectingLaptop - So many issues

lynnalexandra
10 years ago

After having rescued my work laptop from the BSOD - and getting my husband's new laptop up and running - thanks to help here (and Sysnative), I'd like to tackle an ongoing thorn in my side. My home laptop.

This is the most expensive computer I've bought - and the biggest lemon from day one. It has Windows XP - so I know that's not supported after 4/14. Someone suggested I keep it at our beach apartment after that - and use it until I can't. Either way, I'd like to get this running better - and learn more about how to troubleshoot these problems. I run ccleaner regularly;, do all my updates, run Avast, superantispyware, malwarebytes and spywareblaster. Running these rarely turns much up. Occasionally a tracking/adware - but getting rid of those few occasional infected files does not speed things up.

This is a Lenovo Thinkpad X61, Windows XP, 160GB hard drive with 23 GB free space (if necessary, I can delete movies I had on it for travel), Intel Core 2Duo, T8300, 2.4ghz.

Since the beginning (or near to it), the wireless adapter is wonky. It often drops connection - or used to have trouble finding new networks. I called Lenovo about 1 1/2 years ago when it was still under extended warranty. He guided me to do something (I think update drivers) - and it helped for a little while - but slowly got worse. Then this winter, a smart college kid, majoring in computer science, removed some bloatware (like Think advantage solutions - Lenovo's intrusive Helper software). That too may have helped very briefly. Now it doesn't disconnect as often, but still happens a lot. I often have to disable the wireless network adapter and re-enable - or I have to repair network connections. Sometimes this works and sometimes I have to shut it off and start over again.

The Intell Wireless Wifi link 4965AGN. I have an outdated driver from 2010 (13.4.0.139). I went to the Intel site and see that there is a new driver for that adapter Wireless_15.3.1_x32).
I downloaded the newer driver, double clicked to install. It did not install that way. (I had something similar happen when I had to download a new drive for my work laptop and needed guidance from folks at sysnative to get the driver installed on the windows 7 laptop. I tried those instructions to install this driver - but it doesn't work.) Basically, after downloading it, I went to device manager, driver, and selected update driver. it gives a choice to install automatically (recommended). But when I click that it says it can't find it. So then I selected install form a list or specific location. From there Iif I try to search my documents (after I copied the download to my documents) - I can't find it. And I can't find it anywhere except in my downloads - but the downloads folder won't open when I go to device manager (only in explorer). If i pick let me pick the driver from a specific list, the list doesn't show this recently downloaded, updated driver. So I am stuck here and don't know why the driver won't install - or what I can do to install it. This is the most persistent problem I'm having.

But there are newer problems as well:
Earlier this year the battery died, so I replaced it with a generic. That ran hot so I got a the OEM battery from Lenovo. Charges better - and ran cooler for a couple of months, but has become quite hot the last few months. I don't know why the laptop is so hot. I don't know if that' interfering with operation - but it is making it a bit too uncomfortable to keep on my lap for long. Is there anything I can do to get it to run cooler?

Lately (last month or so?), the computer just freezes. I can't get the cursor to any of my tabs. (Firefox). I can't select a new tab. i get stop script errors. What can i do about the stop script errors. I don't really know what that means - but I copied the error below. Sometimes it passes if I wait - and some times I have to restart firefox (or is it the computer I have to restart). Honestly I'm having so many different problems with this computer, I'm loosing track.

A script on this page may be busy, or it may have stopped responding. You can stop the script now, or you can continue to see if the script will complete.

I tried to copy the script error here - but garden web says there's something in the string of characters they cannot post. So I'm going to try posting this message without that. And if that script error is helpful, I will try pasting it in another post.

Script: http://mono.vizu.com/cdn/00/00/73 ... and I can't include the rest - but i see references to condenast, epicurious,

Well - that's three big problems to start with. Any help is much appreciated.

Thank you.
Lynn.

Comments (121)