SHOP BY DEPARTMENT
Houzz Logo Print
coops905

What's going on with my Bosch induction cooktop?

H202
5 years ago

It's been installed for about 1.5 years. Was cooking on two hobs tonight, both on around level 7. About 10 minutes after turning them on, the whole range top essentially shut off and started beeping in three-beep increments (beep-beep-beep-pause), and the display showed "h" (for hot) on the two elements i had been using, and "0" in the two unused hobs. I tried to press all the buttons to see if anything worked (off/on, selecting a different hob, panel lock, etc) but the touch screen was totally non responsive.

As a side note, our house is 150 years old and the electrical was updated over the years and we apparently had enough capacity to install the cooktop when we did the kitchen reno without doing a power-up. But i've always thought this induction unit took longer to boil water than our identical bosch induction cooktop did in our last house, so i've always wondered if the electrical wasn't up to snuff. But i could be imagining that, and/or this could be unrelated.

Ideas?

Comments (14)